Sinatraのあらかると

記録することで、環境構築で悩まない。

rvm

rvmと長い付き合いしていると…

rvmのstableであった黄色のメッセージに遭遇しました。 Warning! PATH is not properly set up, '$HOME/.rvm/gems/ruby-2.0.0-p247/bin' is not at first place, usually this is caused by shell initialization files - check them for 'PATH=...' entries…

必要としないかもしれない環境構築

rvmはオワコンですね、わかってます。 なぜか愛着がわいているんです、 Ruby会議2010のころから、使い始めたから。 環境 rvm homebrew Mountain Lion homebrewであったこんなこと。 rvm install 1.8.7 と1.8.7をインストールしようと実行すると、 以下のよう…

rvmでmrubyの環境構築

北陸地方の桜の開花予定日は4月3日すぎらしいですね。 もう新スタートを始める時期でしょうか。 気持ちも新たに始めたいですね。 今日は、オワコンと呼ばれるrvmでmrubyの環境構築ができないときの対処法を。 シンプルにいきます、 rvmはstableにて、 rvm …

お久しぶりです、今回は依存系の話をします。

しばらく、WordPressの方でzinbeiの情報を更新してました。 バレンタインデーですね、こっちも更新したいと思います。 Mac上のHomebrewでbrew upgradeとすると、 dyld: library not loaded: /usr/local/lib/libintl.8.dylib とエラーがでました。 オンライン…

モヤッと解決する方法。

朝、日が差し始めるときに仕事にいこうと運転しているんですが、 今日は特に寒かった。金沢市の8号線はうっすらと雪が積もってまして、 ノーマルタイヤには辛い時期になりましたが、12月に入るまでタイヤをかえませんよ。 積もったら変えますけど。どっちだ…

エラーの対処です。

最近、月曜日の午前が空き始めました。 こんなときは時間をうまく使って、 問題をひとつ片付けますか。 動作環境はMacです。 最近、Ruby-2.0.0-preview1がrvmに流れ始めました。 rvm install ruby-2.0.0-preview1 インスコしてみようと上記コマンドを実行す…

るびきちさんに感謝。

環境: Ruby1.9.3-p194 rcodetools -0.8.5.0 http://blog.katsuma.tv/2009/05/install_elips.html Emacsを使っていて、 rcodetools.el の導入方法などは上記リンクから入れる。 例をあげるなら、 rvm gemset use takayuki gem install rcodetools /Users/kam…

LionでXcodeを入れてもCコンパイラがないというrvmのエラーは。

うれしいことがあったりして、ちょっと気分がいいときもあり、そんなときこそ油断しないようにいきたいですね。最近、忙しくてなにもエラーを対処してなかったんですが、Rubyネタでもひとつ。Ruby1.9.3-p125がリリースされてますね。 http://www.ruby-lang.o…

結局こうしましたの一例。

rvmで2度目にいれるとcurlのエラーがでた。 これはドキュメントを探しても直し方がわからない。 今、試験の途中なのに…何科目か追試になっているはず。 どうしようか。そうやって考えていたら、rbenvって便利な簡易バージョン管理があるではありませんか。こ…

rvm設置ミスからrbenvで回復までの流れ。

svmというScalaのバージョン管理シェルをみていてわかったことがある。それは、手動でコンパイルしたCRubyをrvmに入れることは可能だということ。さて、やってみるか。 emacs ~/.bash_profile で開いて項目に、 export CC=gcc-4.2 を追加 すでに http://d.ha…

UbuntuでRubyを使う際にちょっとあせったときのメモ。

rubygemsを、 gem update --system などのコマンドで、updateして、 gem -v ってすると NOTE: Gem::Specification#default_executable= is deprecated with no replacement. んな感じでエラーがくっついて回った。 どうにか治せないかって(この場合エラーの…

rvmを更新する方法。

Ruby屋を名乗るためには、1バージョンでは言えないし、資格は絶対必要か…。macで入れるにはどうしたらよいか。 そんなことでまず、それぞれのバージョンを管理するrvmの最新版を手に入れましょう。ということで、どうすればいいだ。 ・Macportからgit-coreを…

Copyright © 2007-2017 Takayuki Kamiyama. All Rights Reserved.