読者です 読者をやめる 読者になる 読者になる

Sinatraのあらかると

記録することで、環境構築で悩まない。

error_messages_forがプラグインになった


DEPRECATION WARNING: error_messages_for was removed from
Rails and is now available as a plugin.
Please install it with `rails plugin install
git://github.com/rails/dynamic_form.git`.

っていうエラーが専門書の内容で作っていると本当にでました。

どうすればいいんだってGKIさんのサイトをみていると、
gitを入れるところから始めるようで、
http://code.google.com/p/git-osx-installer/downloads/list?can=3
からMac版は手に入るって前に日記で書いたはず。
http://d.hatena.ne.jp/emerald00/searchdiary?word=git&.submit=%B8%A1%BA%F7&type=detail
Macではインストーラから入れれるため、
そんなに苦労なくgitを入れれたら、
私のはすでに入っていたんだ…rvmのときに苦労したし。

ターミナルから次のコマンドを打つべし!


rails plugin install git://github.com/rails/dynamic_form.git

インストールが完了したら、webrickをCtrl+Cで止めて、
rails sと打ち直し。これにて、エラーが消えました。

どうもありがとう。GKIさん。助かりました。

GKIさんのサイト「引用先:仕事のねた」
http://hogehoge-gki.blogspot.com/

Copyright © 2007-2017 Takayuki Kamiyama. All Rights Reserved.